CSM.SodaDotNet 0.7.0

Socrata Open Data API client library target .NET 4.5 and above.

Install-Package CSM.SodaDotNet -Version 0.7.0
dotnet add package CSM.SodaDotNet --version 0.7.0

Release Notes

*It is highly recommended to update to this version, as it features improved security following Socrata's deprecation of TLS 1.0*

Security enhancements

 - Disable security protocols lower than TLS 1.1

Bug fixes

 - SoqlQuery no longer inserts default query arguments

New features

 - SoqlQuery supports the $having clause
 - SoqlQuery supports the $query clause

Version History

Version Downloads Last updated
0.7.0 (current version) 551 1/12/2017
0.6.0 557 6/2/2016
0.5.0 897 8/12/2015
0.4.1 251 6/11/2015
0.4.0 179 5/7/2015
0.3.0 243 1/8/2015
0.2.1 208 12/2/2014
0.2.0 660 11/3/2014
0.1.2 188 10/1/2014
0.1.1 177 9/16/2014
0.1.0 205 8/28/2014