Developist.Core.Utilities 1.1.1

A collection of general utilities that are useful in various .NET 5.0 projects. For now, Ensure.Argument (precondition checking) is the main functionality provided.

Install-Package Developist.Core.Utilities -Version 1.1.1
dotnet add package Developist.Core.Utilities --version 1.1.1
<PackageReference Include="Developist.Core.Utilities" Version="1.1.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Developist.Core.Utilities --version 1.1.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Developist.Core.Utilities, 1.1.1"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Developist.Core.Utilities as a Cake Addin
#addin nuget:?package=Developist.Core.Utilities&version=1.1.1

// Install Developist.Core.Utilities as a Cake Tool
#tool nuget:?package=Developist.Core.Utilities&version=1.1.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

  • net5.0

    • No dependencies.

NuGet packages (2)

Showing the top 2 NuGet packages that depend on Developist.Core.Utilities:

Package Downloads
Developist.Core.Cqrs
CQRS messaging library built around an in-process dispatcher. The messages dispatched are command, query and event. Supports wrapping of message handlers to create processing pipelines. Targets .NET 5.0.
Developist.Core.Persistence
Entity Framework Core and in-memory implementations of the Repository and Unit of Work patterns. Targets .NET 5.0.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
1.1.1 70 5/28/2021