FSharp.Core 4.2.1

FSharp.Core for F# 4.1

FSharp.Core redistributables from Visual F# 4.1.0
   Supported Platforms:
       .NET 4.5+           (net45)
       netstandard1.6      (netstandard1.6)

Install-Package FSharp.Core -Version 4.2.1
dotnet add package FSharp.Core --version 4.2.1

Release Notes

FSharp.Core 4.2 (and higher versions) is the version of FSharp.Core which is jointly published by Microsoft and The F# Software Foundation. It is the version of FSharp.Core to be used for .NET Standard 2.0 or .NET Core 2.0 projects, and eventually all projects. It no longer contains PCL .dlls. This is not intended for use in PCL or Type Providers yet.

Guidance for this version:

* For existing packages targeting .NET Frameworks 4.0 or lower and PCLs, use FSharp.Core 4.1 or lower.
* For Type Provider developers, use FSharp.Core 4.1 or lower until Type Providers are supported on .NET Standard 2.0
* For existing desktop projects or libraries, prefer this version or higher if feasible.
* For new desktop projects or libraries, use this version or higher.
* For new (.NET Standard-based) Xamarin projects, use this version or higher.
* For library developers, prefer this package if you can target .NET Standard 1.6 or 2.0. Multitarget to also provide a .NET Framework 4.5 .dll, if possible, to provide a wider range of targets for desktop users who cannot use .NET Standard.

Version History

Version Downloads Last updated
4.2.3 0 8/19/2017
4.2.2 10,708 7/28/2017
4.2.1 (current version) 35,677 6/8/2017
4.2.0 (deleted) 2218 6/1/2017
4.1.18 0 8/19/2017
4.1.17 89,096 4/29/2017
4.0.0.1 405,640 7/23/2015
3.1.2.5 127,969 7/18/2015
3.1.2 3,368 12/3/2014
3.0.2 18,479 12/3/2014