FluentMigrator 1.5.0

FluentMigrator is a database migration framework for .NET written in C#. The basic idea is that you can create migrations which are simply classes that derive from the Migration base class and have a Migration attribute with a unique version number attached to them. Upon executing FluentMigrator, you tell it which version to migrate to and it will run all necessary migrations in order to bring your database up to that version.
     In addition to forward migration support, FluentMigrator also supports different ways to execute the migrations along with selective migrations called profiles and executing arbitrary SQL.

There is a newer version of this package available.
See the version list below for details.
Install-Package FluentMigrator -Version 1.5.0
dotnet add package FluentMigrator --version 1.5.0
<PackageReference Include="FluentMigrator" Version="1.5.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add FluentMigrator --version 1.5.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

https://github.com/schambers/fluentmigrator/releases



Features:

   #467 - Allow many assemblies to contribute IMigrations in the same migrations run (JulianRooze)
   #529 - Support SAP HANA Database (FabioNascimento)
   #570 - Add options to generate migrations without database connection (andrewhanson)
   #577 - Added ability to set Transaction Behavior and use Tags with MaintenanceAttribute (unrealguard)

Improvements:

   #553 - Postgresql now handles comments (itn3000)
   #573 - Provides an ability to create a column and specify that the timezone information should be stored with the date (dealproc)

Fixes:

   #572 - SetExistingRowsTo: will not longer change column length (mstancombe)
   #585 - Jet: Added Transaction to expression.Operation (albatrossen)
   #576 - Firebird: quote only keywords otherwise quoting should be optional and not the default & various (amroel)
   #568 - Oracle: Fix Escaping of Guid's, for insertdataexpression etc (tommarien)

Various:

   #565 Albacore upgrade to 2.0 (daniellee)

Dependencies

This package has no dependencies.

Version History

Version Downloads Last updated
3.2.1 1,072 4/16/2019
3.2.0 141 4/15/2019
3.1.3 211,485 6/25/2018
3.1.2 2,456 6/21/2018
3.1.1 9,552 6/11/2018
3.1.0 2,752 6/1/2018
3.0.0 11,466 5/7/2018
2.0.7 15,777 4/27/2018
2.0.6 10,848 4/24/2018
2.0.5 1,177 4/23/2018
2.0.4 371 4/23/2018
2.0.3 808 4/22/2018
2.0.2 14,392 4/17/2018
2.0.1 1,574 4/16/2018
2.0.0 1,303 4/15/2018
1.6.2 762,941 5/31/2016
1.6.1 204,367 11/9/2015
1.6.0 65,046 7/13/2015
1.5.1 39,831 4/17/2015
1.5.0 28,902 2/27/2015
1.4.0 26,109 12/31/2014
1.3.1 21,004 11/18/2014
1.3.0 71,318 8/27/2014
1.2.1 14,835 7/12/2014
1.2.0 5,599 6/18/2014
1.1.2.1 47,108 1/1/2014
1.1.2 988 12/29/2013
1.1.1 48,227 6/26/2013
1.1.0 14,880 5/5/2013
1.0.6 47,796 12/31/2012
1.0.5 7,635 11/15/2012
1.0.4 3,155 10/27/2012
1.0.3 9,464 7/19/2012
1.0.2 4,829 4/25/2012
1.0.1 12,286 9/5/2011
0.9.2 1,953 7/24/2011
0.9.1 1,052 7/24/2011
0.9.0 2,267 1/7/2011
Show less