Mobiscroll-jqMobi 2.3.0

Mobiscroll package for jqMobi

There is a newer version of this package available.
See the version list below for details.
Install-Package Mobiscroll-jqMobi -Version 2.3.0
dotnet add package Mobiscroll-jqMobi --version 2.3.0
<PackageReference Include="Mobiscroll-jqMobi" Version="2.3.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Mobiscroll-jqMobi --version 2.3.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

Changelog 2.3

Enhancements

Core

 - Changed: prevent collisions if core is loaded multiple times

 - Changed: validate and onChange event runs on scrolling animation end providing a more fluid user experience (#36)

 - Changed: user defined event handlers does not override preset event handlers

 - Added: onShow gets an additional valueText parameter

 - Added: onAnimStart event, which is fired at scrolling animation start, and receives the wheel index, animation time, and the mobiscroll instance as parameters

 - Added: shorthand form for presets: $('.selector').mobiscroll().date(). To add a shorthand for your own preset, just add the following line in your preset code: $.mobiscroll.presetShort('mypresetname')

 - Added: highlight selected entry on tap

Select preset

 - Changed: make it work with late validation

List preset

 - Changed: make it work with late validation

Themes

 - Changed: prevent collisions if themes are loaded multiple times

Bugfixes

Core

 - Fixed: don't do tap ahead, if moving wheel was stopped with a tap

 - Fixed: setValue method was not working correctly (#43)

 - Fixed: if close was canceled (onClose returned false), the value was still set

Datetime preset

 - Fixed: closing tag for the short day name and short month name span was incorrectly added

Select preset

 - Fixed: onChange, onSelect, onCancel events received the disabled value, if the user scrolled to a disabled option, event though on the UI was not selectable (#40)

Rating preset

 - Fixed: stars were not aligned to middle in Firefox and IE

Dependencies

This package has no dependencies.

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
2.13.2 958 10/22/2014
2.13.0 497 9/19/2014
2.12.0 432 7/22/2014
2.12.0-beta 390 7/8/2014
2.11.1 423 6/5/2014
2.11.0 413 5/15/2014
2.10.1 461 4/22/2014
2.9.5 476 3/12/2014
2.9.4 442 2/26/2014
2.9.3 406 2/10/2014
2.9.2 421 1/21/2014
2.9.1 411 1/10/2014
2.8.3 447 11/15/2013
2.8.2 408 11/4/2013
2.8.1 433 10/28/2013
2.8.0 466 10/10/2013
2.7.2 512 9/11/2013
2.6.2 498 7/4/2013
2.6.1 452 7/2/2013
2.6.0 465 6/19/2013
2.5.4 478 5/13/2013
2.5.3 543 5/3/2013
2.5.2 448 4/19/2013
2.5.1 467 4/17/2013
2.5.0 468 3/28/2013
2.4.5 473 3/14/2013
2.4.4 489 2/22/2013
2.4.3 492 2/15/2013
2.4.2 482 2/13/2013
2.4.1 556 2/6/2013
2.4.0 506 1/28/2013
2.3.1 508 12/18/2012
2.3.0 506 12/10/2012
2.2.0 591 11/22/2012
Show less