Plisky.Diagnostics 3.1.5

.NET 5.0 .NET Standard 2.0 .NET Framework 4.5.2
Install-Package Plisky.Diagnostics -Version 3.1.5
dotnet add package Plisky.Diagnostics --version 3.1.5
<PackageReference Include="Plisky.Diagnostics" Version="3.1.5" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Plisky.Diagnostics --version 3.1.5
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Plisky.Diagnostics, 3.1.5"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Plisky.Diagnostics as a Cake Addin
#addin nuget:?package=Plisky.Diagnostics&version=3.1.5

// Install Plisky.Diagnostics as a Cake Tool
#tool nuget:?package=Plisky.Diagnostics&version=3.1.5
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Plisky Diagnostics Library - featuring Bilge and Piffle, offering comprehensive trace and error handling facilities to applications.

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net452 net46 net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.
  • .NETFramework 4.5.2

    • No dependencies.
  • .NETFramework 4.6.2

    • No dependencies.
  • .NETFramework 4.7.2

    • No dependencies.
  • .NETFramework 4.8

    • No dependencies.
  • .NETStandard 2.0

    • No dependencies.
  • net5.0

    • No dependencies.
  • net6.0

    • No dependencies.

NuGet packages (3)

Showing the top 3 NuGet packages that depend on Plisky.Diagnostics:

Package Downloads
Plisky.Plumbing

Plisky Plumbing Functions including Hub, ConfigHub, CommandLineSupport.

Plisky.Testing

Plisky Unit Testing Support, TestData TestSupport and Test File Handling.

Plisky.Services.Client

Plisky Client Services Library, provides access to Plisky services including authentication, content and feature management.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
3.1.5 93 3/13/2022
3.1.4 116 1/24/2022
3.1.3 245 12/27/2021
3.0.0 247 5/30/2021
2.8.22 277 11/16/2020
2.8.20 234 11/13/2020
2.8.19 227 11/8/2020
2.8.18 239 11/8/2020
2.8.17 297 11/7/2020
2.8.16 318 11/7/2020
2.8.15 293 11/1/2020
2.8.11 314 9/27/2020
2.8.10 347 7/29/2020
2.8.9 332 7/29/2020
2.8.8 349 7/29/2020
2.8.7 351 7/29/2020
2.8.6 345 7/22/2020
2.8.3 456 5/31/2020
2.8.2 33,841 4/7/2020
2.8.0 1,021 3/9/2020
2.7.1 386 2/23/2020
2.7.0 406 1/31/2020
2.6.2.4 270 1/30/2020
2.6.2.3 288 1/30/2020
2.6.2.2 274 1/30/2020
2.6.2.1 290 1/30/2020
2.6.1 678 6/22/2019
2.6.0 786 6/14/2019
2.5.0 327 6/14/2019
2.4.0 442 6/11/2019
2.3.3 382 6/8/2019
2.3.2 390 6/8/2019
2.3.1 382 5/22/2019
2.3.0 366 5/16/2019
2.2.3 371 5/9/2019
2.2.2 420 3/22/2019
2.2.1 668 8/31/2018
2.2.0 2,228 8/30/2018
2.1.1 619 5/16/2018
2.1.0 793 5/13/2018
2.0.9 837 3/23/2018
2.0.8 651 3/22/2018
2.0.4 759 2/11/2018
2.0.3 1,135 1/21/2018
2.0.2 672 1/21/2018
2.0.0.10 746 1/13/2018
2.0.0.9 752 1/7/2018
2.0.0.7 1,157 11/11/2017
2.0.0.6 728 9/9/2017
2.0.0.5 599 9/9/2017
2.0.0.4 608 9/9/2017
2.0.0.3 625 7/15/2017
2.0.0.2 656 7/2/2017
2.0.0.1 648 6/16/2017
2.0.0-Unicorn0 672 5/31/2017

3.1.2
X Issue with older framework versions in 3.1.0 resolved. (3.1.1/0 Superceeded)
+ Removed support for .net framework 4.0 ( 4.5.2 still present)

3.1.0
+ Improved flush capability for slower handlers ( RollingFileHandler ).
+ Common Bilge.Default added for those tiny little quick traces.

3.0.0
+ Major Version Uplift - Actions Added.
+ Actions - Allow hooks on activities perfomed in code to support unit testing
+ Bilge.B Static common trace added for small utiltiies etc - init string bilge-common.
+ Allow use of Formatters on all default handlers.  New FlimFlam2 Formatter added.
+ Alert now returns a string with a summary title that can be used in other logging.
+ Support for 462, 472, 48 Framework Versions Added.
X Bug Fix - Correct information on trace level written to listeners for Error, Log, Verbose.

2.8.6
+Added Alerting level,
+AppOnline
+Added Init From File and environment variable.
+Statics for configuring and adding handlers (reduce duplicates etc)

2.8.2
X Flush Fix, flush only worked under load.

2.8.1 - Listeners Fix, SimpleFileListener Fix 2.8.0 Superceeded.
2.8.0 - INTERFACE BREAK.... TraceLevel is now SourceLevels, new Feature Bilge.SetConfigurationResolver allows SourceSwitches and TraceSwitches.
2.7.2 - Missing method exception issues resolved  (Critical fix for 2.7.X and 2.6.X)
2.7.0 - Utter Mare on constructors, changing interface.