glm 0.9.9.500

OpenGL Mathematics (GLM) is a header only C++ mathematics library for graphics software based on the OpenGL Shading Language (GLSL) specifications.

GLM provides classes and functions designed and implemented with the same naming conventions and functionalities than GLSL so that anyone who knows GLSL, can use GLM as well in C++.

This project isn't limited to GLSL features. An extension system, based on the GLSL extension conventions, provides extended capabilities: matrix transformations, quaternions, data packing, random numbers, noise, etc...

This library works perfectly with OpenGL but it also ensures interoperability with other third party libraries and SDK. It is a good candidate for software rendering (raytracing / rasterisation), image processing, physic simulations and any development context that requires a simple and convenient mathematics library.

GLM is written in C++98 but can take advantage of C++11 when supported by the compiler. It is a platform independent library with no dependence and it officially supports the following compilers:
- Apple Clang 4.0 and higher
- GCC 4.2 and higher
- Intel C++ Composer XE 2013 and higher
- LLVM 3.0 and higher
- Visual C++ 2010 and higher
- CUDA 4.0 and higher (experimental)
- Any conform C++98 or C++11 compiler

Note: The last number of the version number differs in that respect, that the official fourth number is multiplied to 100. This way the nuget package can be updated for different packages. For example:
- glm 0.9.9.1 => package 0.9.9.100 (first package)
- glm 0.9.9.1 => package 0.9.9.101 (same content, but package updated, e.g. build scripts)
- glm 0.9.9.2 => package 0.9.9.200
- glm 0.9.9.3 => package 0.9.9.300

Install-Package glm -Version 0.9.9.500
dotnet add package glm --version 0.9.9.500
<PackageReference Include="glm" Version="0.9.9.500" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add glm --version 0.9.9.500
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

[GLM 0.9.9.5](https://github.com/g-truc/glm/releases/tag/0.9.9.5) - 2019-04-01
#### Fixes:
- Fixed build errors when defining GLM_ENABLE_EXPERIMENTAL #884 #883
- Fixed 'if constexpr' warning #887
- Fixed missing declarations for frexp and ldexp #886

Dependencies

This package has no dependencies.

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
0.9.9.500 2,660 4/5/2019
0.9.9.400 775 3/19/2019
0.9.9.300 2,681 11/18/2018
0.9.9.200 913 10/20/2018
0.9.9.100 147 10/20/2018
0.9.9 1,845 7/11/2018
0.9.8.5 4,051 3/13/2018
0.9.8.4 3,488 6/20/2017