AryaBootstrap 4.4.1

dotnet add package AryaBootstrap --version 4.4.1
NuGet\Install-Package AryaBootstrap -Version 4.4.1
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="AryaBootstrap" Version="4.4.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add AryaBootstrap --version 4.4.1
#r "nuget: AryaBootstrap, 4.4.1"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install AryaBootstrap as a Cake Addin
#addin nuget:?package=AryaBootstrap&version=4.4.1

// Install AryaBootstrap as a Cake Tool
#tool nuget:?package=AryaBootstrap&version=4.4.1

AryaBootstrap

AryaBootstrap is a bootstrap with dual layout align support and, used for LTR and RTL web design.

Based on Bootstrap Ver 4.4.1

AryaBootstrap is an open source toolkit for developing with HTML, CSS, and JS. Quickly prototype your ideas or build your entire app with our templates, responsive grid system, extensive prebuilt components, and powerful plugins built on jQuery. This Version of AryaBootstrap is based on Bootstrap Ver 4.4.1 and all bootstrap feature is provided.

Installation

Installation AryaBootstrap is as simple as Bootstrap.

1. First of all, Download the github AryaBootstrap repository، GitHub. or install it from nuget packages.

Extract the files and folders, copy Css and Js folders to your project.

2. Add Css file to your pages

Add Css file link to your page like the below HTML code:

<link rel="stylesheet" type="text/css" href="css/bootstrap.min.css" /> 
3. Add Js files to your page

Some bootstrap components need bootstrap.js for doing well on the page. and they used jQuery library. so you have to add jQuery (slim version is enuogh) file before add bootstrap js file.

Bootstrap used popper.js to provide grid system and you have to add popper.js after jQuery file.

At the end, you have to add Bootstrap.js

<script type="text/javascript" src="js/jquery.slim.min.js"></script>
<script type="text/javascript" src="js/popper.min.js"></script>
<script type="text/javascript" src="js/bootstrap.min.js"></script>

Also, you can use the bootstrap CDN files insted use of downloaded files:

<script src="https://code.jquery.com/jquery-3.4.1.slim.min.js" integrity="sha384-J6qa4849blE2+poT4WnyKhv5vZF5SrPo0iEjwBvKU7imGFAV0wwj1yYfoRSJoZ+n" crossorigin="anonymous"></script>
<script src="https://cdn.jsdelivr.net/npm/popper.js@1.16.0/dist/umd/popper.min.js" integrity="sha384-Q6E9RHvbIyZFJoft+2mJbHaEWldlvI9IOYy5n3zV9zzTtmI3UksdQRVvoxMfooAo" crossorigin="anonymous"></script>
<script src="https://stackpath.bootstrapcdn.com/bootstrap/4.4.1/js/bootstrap.min.js" integrity="sha384-wfSDF2E50Y2D1uUdj0O3uMBJnjuUD4Ih7YwaYd1iqfktj0Uod8GCExl3Og8ifwB6" crossorigin="anonymous"></script>
4. Latest and Important Step

Add "dir" property to your "html" tag. use dir="rtl" for RTL layout and dir="ltr" for LTR layout.

<html dir="rtl">

Everything is Done! run your project and enjoy the rtl bootstrap.

Check the AryaBootstrap Website, there are some sample and articles (Persian Version).

AryaBootstrap Website

Persian Version is also avilable at Persian ReadMe
There are no supported framework assets in this package.

Learn more about Target Frameworks and .NET Standard.

This package has no dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
4.4.1 1,188 3/25/2020