CS-Script.RoslynProvider 3.30.0

The CodeDom provider for CS-Script Class Library that targets Roslyn.

Install-Package CS-Script.RoslynProvider -Version 3.30.0
dotnet add package CS-Script.RoslynProvider --version 3.30.0
<PackageReference Include="CS-Script.RoslynProvider" Version="3.30.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add CS-Script.RoslynProvider --version 3.30.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

- Issue #25: Feature request to support conditional directives
- Issue #160: Compatibility with old script syntax
- Issue #161: Assembly is (tried to be) loaded from GAC instead of local dir
- Triggered by issue #172: CsvHelper loads the wrong ValueTuple version in CSScript?
- Issue #173: C# script installation on Window10 / WSL linux does not work
- Added support for _gitignore_ syntax in `//css_` directives (e.g. `//css_ref .\**\Release\*.dll`)
- Added processing precompilers output for `-proj` option
- Added debugVS2019.cs
- Improved version info output
- Fixed all urls pointing to the old web hosting
- Added support for PreferredRuntime of the dependency packages when resolving them.
- Added VB samples for NuGet package (partial solution for #155)
- Added syntax help output info

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
3.30.0 20 10/14/2019
3.29.0 157 5/22/2019
3.28.7 425 9/2/2018
3.28.4 417 4/28/2018
3.28.2 1,526 3/15/2018
3.28.0.1 1,286 2/5/2018
3.28.0 231 2/4/2018
3.27.0 351 7/19/2017
3.26.2 636 6/30/2017