Cqrs.Ninject 5.1.0.44

dotnet add package Cqrs.Ninject --version 5.1.0.44
NuGet\Install-Package Cqrs.Ninject -Version 5.1.0.44
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Cqrs.Ninject" Version="5.1.0.44" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Cqrs.Ninject --version 5.1.0.44
#r "nuget: Cqrs.Ninject, 5.1.0.44"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install Cqrs.Ninject as a Cake Addin
#addin nuget:?package=Cqrs.Ninject&version=5.1.0.44

// Install Cqrs.Ninject as a Cake Tool
#tool nuget:?package=Cqrs.Ninject&version=5.1.0.44

Provides preconfigured Ninject modules that will wire up the required component necessary.

Several modules are optional such as the InProcess or the SimplaifySQL modules. You only need to use those if you are using InProcess or SQL.

Product Compatible and additional computed target framework versions.
.NET net5.0 was computed.  net5.0-windows was computed.  net6.0 was computed.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp2.0 was computed.  netcoreapp2.1 was computed.  netcoreapp2.2 was computed.  netcoreapp3.0 was computed.  netcoreapp3.1 was computed. 
.NET Standard netstandard2.0 is compatible.  netstandard2.1 was computed. 
.NET Framework net40 is compatible.  net403 was computed.  net45 was computed.  net451 was computed.  net452 was computed.  net46 was computed.  net461 was computed.  net462 was computed.  net463 was computed.  net47 was computed.  net471 was computed.  net472 was computed.  net48 was computed.  net481 was computed. 
MonoAndroid monoandroid was computed. 
MonoMac monomac was computed. 
MonoTouch monotouch was computed. 
Tizen tizen40 was computed.  tizen60 was computed. 
Xamarin.iOS xamarinios was computed. 
Xamarin.Mac xamarinmac was computed. 
Xamarin.TVOS xamarintvos was computed. 
Xamarin.WatchOS xamarinwatchos was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (9)

Showing the top 5 NuGet packages that depend on Cqrs.Ninject:

Package Downloads
Cqrs.Ninject.Azure.ServiceBus.CommandBus

Use Ninject as your IoC container of choice when using Microsoft Azure ServiceBus for CQRS.NET as your command bus

Cqrs.Ninject.Azure.ServiceBus.EventBus

Use Ninject as your IoC container of choice when using Microsoft Azure ServiceBus for CQRS.NET as your event bus

Cqrs.Ninject.InProcess.CommandBus

Deprecated. Use the Cqrs.Ninject package instead.

Cqrs.Ninject.InProcess.EventBus

Deprecated. Use the Cqrs.Ninject package instead.

Cqrs.Ninject.InProcess.EventStore

Deprecated. Use the Cqrs.Ninject package instead.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
5.1.0.44 4,456 1/19/2024
5.0.0.43 173 1/17/2024
5.0.0.42 253 1/15/2024
5.0.0.41 210 1/15/2024
5.0.0.40 204 1/15/2024
5.0.0.39 190 1/15/2024
5.0.0.38 222 1/14/2024
5.0.0.37 185 1/14/2024
5.0.0.36 220 1/13/2024
5.0.0.35 270 12/15/2023
5.0.0.34 315 12/10/2023
5.0.0.33 317 12/8/2023
5.0.0.32 790 11/19/2023
5.0.0.31 307 11/18/2023
5.0.0.30 3,747 10/23/2023
5.0.0.29 285 10/22/2023
5.0.0.28 214 10/19/2023
4.5.1.27 210 10/2/2023
4.5.1.26 156 10/2/2023
4.4.1.24 2,133 11/21/2022
4.4.1.23 1,586 10/21/2022
4.4.1.22 955 10/21/2022
4.4.1.21 1,232 10/13/2022
4.3.20 2,469 7/24/2022
4.3.19 1,196 7/23/2022
4.3.18 1,714 6/25/2022
4.3.17 1,184 6/25/2022
4.3.16 1,187 6/25/2022
4.3.15 1,659 6/23/2022
4.3.14 1,954 6/10/2022
4.3.13 1,326 6/9/2022
4.3.10 1,374 6/8/2022
4.3.9 2,027 5/30/2022
4.3.8 3,002 4/16/2022
4.3.7.2083851369 1,581 4/3/2022
4.3.6.2083241347 1,447 4/2/2022
4.3.3.1240345038 7,850 9/16/2021
4.2.1736.932 2,162 4/11/2021
4.2.1734.929 1,677 4/11/2021
4.2.1733.928 1,812 4/11/2021
4.2.1729.923 3,838 9/17/2020
4.2.1728.922 1,664 9/17/2020
4.2.1724.919 2,420 12/27/2019
4.2.1723.918 1,669 12/27/2019
4.2.1721.916 1,666 12/26/2019
4.2.1720.915 2,104 12/26/2019
4.2.1719.914 1,622 12/26/2019
4.2.1717.912 1,868 12/26/2019
4.2.1715.911 1,635 12/26/2019
4.2.1713.909 2,092 12/26/2019
4.2.1711.907 1,890 12/26/2019
4.2.1710.906 1,632 12/26/2019
4.1.1706.902 1,619 11/25/2019
4.1.1699.898 1,304 11/25/2019
4.1.1695.893 1,367 11/25/2019
4.1.1694.892 1,309 11/24/2019
4.1.1694.889 675 11/24/2019
4.0.1687.883 1,147 11/23/2019
4.0.1670.873 1,183 11/23/2019
4.0.1663.868 647 11/22/2019
4.0.1659.865 649 11/22/2019
4.0.1659.864 664 11/22/2019
2.4.1639.856 2,981 8/17/2018
2.4.1622.842 2,353 6/29/2018
2.4.1621.841 2,504 6/24/2018
2.4.1619.839 2,432 6/24/2018
2.3.1595.820 2,474 3/29/2018
2.3.1584.809 2,485 3/20/2018
2.3.1583.808 2,502 3/20/2018
2.3.1581.806 2,513 3/15/2018
2.3.1580.805 2,418 3/8/2018
2.3.1579.804 2,454 3/8/2018
2.3.1572.797 2,493 2/19/2018
2.2.1466.702 2,485 9/18/2017
2.2.1440.678 2,521 8/1/2017
2.2.1428.666 2,397 7/25/2017
2.2.1410.652 2,513 7/23/2017
2.2.1405.647 2,346 7/21/2017
2.1.1347.590 1,833 6/23/2017
2.0.1317.561 1,287 6/6/2017
1.601.1007 1,441 5/24/2016
1.601.954 1,540 5/2/2016
1.601.790 1,598 2/23/2016
1.601.787 1,401 11/2/2015
1.500.403.298 1,520 11/15/2014
1.500.395.288 1,848 11/7/2014
1.500.393.286 1,622 11/5/2014
1.500.368.263 1,753 11/3/2014

Version 4.3.7

* Addressed a poorly configured null or empty string AuthenticationTokenType

Version 4.1.0

* Switched to .NET Standard 2.0 support from .NET Core 3.0.

Version 4.0.0

* Added .NET Core 3.0 support.

Breaking Changes

* Automapper is only configured and support for .NET Framework, not .NET Core. It's only used by SQL elements like Linq2SQL which isn't supported in .NET Core anyway.