EnsureThatCore 1.0.0

.NET Core 2.0 & Standard 2.0 port of A simple guard clause project helping you with validation and uniformed exception throwing when validating arguments.

Install-Package EnsureThatCore -Version 1.0.0
dotnet add package EnsureThatCore --version 1.0.0
<PackageReference Include="EnsureThatCore" Version="1.0.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add EnsureThatCore --version 1.0.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

https://github.com/danielwertheim/ensure.that/blob/master/ReleaseNotes.md

  • .NETCoreApp 1.1

  • .NETCoreApp 2.0

    • No dependencies.
  • .NETFramework 4.5

    • No dependencies.
  • .NETFramework 4.7

    • No dependencies.
  • .NETStandard 1.6

  • .NETStandard 2.0

    • No dependencies.

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
1.0.0 16,054 7/17/2017