Essentials.Domain 1.3.1

Install-Package Essentials.Domain -Version 1.3.1
dotnet add package Essentials.Domain --version 1.3.1
<PackageReference Include="Essentials.Domain" Version="1.3.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Essentials.Domain --version 1.3.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Essentials.Domain, 1.3.1"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Essentials.Domain as a Cake Addin
#addin nuget:?package=Essentials.Domain&version=1.3.1

// Install Essentials.Domain as a Cake Tool
#tool nuget:?package=Essentials.Domain&version=1.3.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Contains a bunch of interfaces, abstract classes, etc... to easily deal with domain driven architectures

  • .NETFramework 4.5

    • No dependencies.
  • .NETStandard 2.0

    • No dependencies.

NuGet packages (3)

Showing the top 3 NuGet packages that depend on Essentials.Domain:

Package Downloads
Essentials.Infrastructure

Contains a bunch of interfaces, abstract classes, etc... to easily deal with DDD infrastructure layer

Essentials.Infrastructure.Dapper

Contains Dapper specific implementation for infrastructure layer

Essentials.Application

Contains a bunch of interfaces, abstract classes, etc... to easily deal with domain driven architectures in the application layer.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.3.1 642 4/11/2019
1.3.0 581 4/11/2019
1.2.0 570 12/18/2018
1.1.0 602 12/3/2018
1.0.1 787 6/18/2018
1.0.0-CI-20180608-125130 551 6/8/2018