FirebaseRestTranslator 0.1.2

dotnet add package FirebaseRestTranslator --version 0.1.2
NuGet\Install-Package FirebaseRestTranslator -Version 0.1.2
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="FirebaseRestTranslator" Version="0.1.2" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add FirebaseRestTranslator --version 0.1.2
#r "nuget: FirebaseRestTranslator, 0.1.2"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install FirebaseRestTranslator as a Cake Addin
#addin nuget:?package=FirebaseRestTranslator&version=0.1.2

// Install FirebaseRestTranslator as a Cake Tool
#tool nuget:?package=FirebaseRestTranslator&version=0.1.2

FirebaseRestTranslator

CircleCI

This is a small helper class that can be used to translate C# dictionaries into the Firebase REST format so they be posted to Firebase directly.

See the tests for usage.

    [Fact]
    public void Test_FirebaseTranslator_BoolValue()
    {
        var data = new Dictionary<string, object>()
        {
            ["myKey"] = false
        };
        var expectedJson = "{\"name\":\"Test_FirebaseTranslator\",\"fields\":{\"myKey\":{\"booleanValue\":false}}}";
        var result = Translator.Translate("Test_FirebaseTranslator", data);
        var actualJson = JsonConvert.SerializeObject(result);
        Assert.Equal(expectedJson, actualJson);
    }

Changelog

0.1.2

  • Added support for uint, long types.
Product Compatible and additional computed target framework versions.
.NET net5.0 was computed.  net5.0-windows was computed.  net6.0 was computed.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp3.0 is compatible.  netcoreapp3.1 was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.
  • .NETCoreApp 3.0

    • No dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
0.1.2 351 4/30/2021
0.1.1 601 3/7/2020