Foster 1.0.0

Install-Package Foster -Version 1.0.0
dotnet add package Foster --version 1.0.0
<PackageReference Include="Foster" Version="1.0.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Foster --version 1.0.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Foster, 1.0.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Foster as a Cake Addin
#addin nuget:?package=Foster&version=1.0.0

// Install Foster as a Cake Tool
#tool nuget:?package=Foster&version=1.0.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Foster

C# Library & tools for version controlling.

Used in Haltroy apps like Yorot and Backupster.

Foster can be used for everything with Foster Manager

  • Nuget Website
  • Wiki API
  • Website Source

Versions

Requirements

Foster only requires .NET Standard 2.0 or newer supported projects. They can be installed on these frameworks:

  • .NET 5.0 or newer
  • .NET Framework 4.6.1 or newer
  • .NET Core 2.0 or newer
  • Mono 5.4 or newer
  • Xamarin.iOS 10.14 or newer
  • Xamarin.Mac 3.8 or newer
  • Xamarin.Android 8.0 or newer
  • Universal Windows Platform 10.0.16299 or newer
  • Unity 2018,1 or newer

Features

  • No-compression, GZip, LZMA and Deflate support
  • XML parser support
  • Updating projects
  • Auto update checking
  • Delta package support
  • Packing & Unpacking
  • Delta creation & Delta application
  • Batch-creating packages
  • Install/Update Foster file
  • Shortcuts support

Usage

Foster Packages

You can install them with NuGet (or Nuget Package Manager in Visual Studio) to your project. The commands to install those packages can be found easily on their own NuGet listings.

You can use the packages in their supported projects in both C# and VB.NET by simply adding using Foster;/Imports Foster (C#/VB.NET) on top of the source files (.cs for C# projects, .vb for VB.NET projects).

To create a .Foster file, you can see examples here.

Development

Foster can be developed under any operating systems. The only requirement is that .NET SDK (in most package managers, dotnet-sdk) should be installed to the machine.

If you dualboot your system with 2 completely different operating systems (ex. Windows 10/11 & any GNU/Linux distribution), please execute the cleanup.py Python script before development. This will fix most of the problems with OmniSharp.

Releases

Branch/Version Standart Status Release Time
master .NET Standard 2.0 Main pls send jokes to put here thanks
2.0.0.0 .NET Standard 2.0 Development 2022
1.0.0.0 .NET Standard 2.0 Latest Release 31 December 2021
  • .NETStandard 2.0

    • No dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.0.0 45 12/31/2021
1.0.0-preview1 26 12/25/2021

Please go to https://github.com/Haltroy/Foster/releases to see the changes.