LtiLibrary 1.4.5

A .NET library with IMS LTI support for Tool Consumer and Tool Provider applications. Supports IMS LTI 1.0, 1.1, 1.1.1 and draft 1.2.

This is the last version of the unified LtiLibrary library. Please see LtiLibrary.Core and LtiLibrary.AspNet for newer versions.

Install-Package LtiLibrary -Version 1.4.5
dotnet add package LtiLibrary --version 1.4.5
<PackageReference Include="LtiLibrary" Version="1.4.5" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add LtiLibrary --version 1.4.5
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

1.4.5
- Fixed: Realm should be excluded for OAuth 1.0 "Signature Base String" calculation.
- This is the last version of the unified LtiLibrary library. Please see LtiLibrary.Core and LtiLibrary.AspNet for newer versions.
1.4.4
- Updated HtmlAgilityPack to version 1.4.8
- Updated Microsoft.AspNet.WebApi to version 5.2.2
- Updated Newtonsoft.Json to version 6.0.5
1.4.3
- Bug fixes
1.4.2      
- Support for the Public Draft of LTI 1.2.
- Support for the Public Draft of LTI Content-Item Message Version 1.0.

See https://ltisamples.codeplex.com/documentation for details.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
1.4.5 13,420 11/2/2014
1.4.4 850 9/19/2014
1.4.3 610 8/16/2014
1.4.2 954 5/10/2014
1.4.2-draft 512 5/4/2014
1.4.1-draft 555 5/4/2014
1.4.0-draft 497 3/29/2014
1.3.3 708 12/14/2013
1.3.2 552 12/14/2013
1.3.1 558 12/9/2013
1.3.0 600 12/9/2013
1.2.6001.31627 556 12/8/2013
1.2.6000.31710 621 12/2/2013
1.2.0.22821 698 12/1/2013