NWebsec.AspNetCore.Core 3.0.1

Install-Package NWebsec.AspNetCore.Core -Version 3.0.1
dotnet add package NWebsec.AspNetCore.Core --version 3.0.1
<PackageReference Include="NWebsec.AspNetCore.Core" Version="3.0.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add NWebsec.AspNetCore.Core --version 3.0.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: NWebsec.AspNetCore.Core, 3.0.1"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install NWebsec.AspNetCore.Core as a Cake Addin
#addin nuget:?package=NWebsec.AspNetCore.Core&version=3.0.1

// Install NWebsec.AspNetCore.Core as a Cake Tool
#tool nuget:?package=NWebsec.AspNetCore.Core&version=3.0.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

This library provides shared functionality for the NWebsec ASP.NET Core security libraries.

  • .NETCoreApp 3.1

    • No dependencies.

NuGet packages (3)

Showing the top 3 NuGet packages that depend on NWebsec.AspNetCore.Core:

Package Downloads
NWebsec.AspNetCore.Middleware

NWebsec middleware for ASP.NET Core applications. NWebsec helps you set important security headers and detect potentially dangerous redirects. See project website for documentation.

NWebsec.AspNetCore.Mvc

NWebsec attributes for ASP.NET Core MVC applications. NWebsec helps you set important security headers, detect potentially dangerous redirects, and control cache headers. See project website for documentation.

Bnsights.Coreib

Package Description

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
3.0.1 80,244 2/12/2020
3.0.0 1,905,838 1/13/2020
3.0.0-188.rc 595 1/12/2020
2.0.0 2,576,942 3/25/2018
1.1.0 185,117 3/28/2017
1.0.0 5,565 3/8/2017

This release fixes a bug that caused a validation exception on some valid CSP scheme sources containing the characters '+.-'.