Walterlv.WeakEvents 7.3.1

.NET Core 3.0 .NET Standard 2.0 .NET Framework 4.5
Install-Package Walterlv.WeakEvents -Version 7.3.1
dotnet add package Walterlv.WeakEvents --version 7.3.1
<PackageReference Include="Walterlv.WeakEvents" Version="7.3.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Walterlv.WeakEvents --version 7.3.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Walterlv.WeakEvents, 7.3.1"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Walterlv.WeakEvents as a Cake Addin
#addin nuget:?package=Walterlv.WeakEvents&version=7.3.1

// Install Walterlv.WeakEvents as a Cake Tool
#tool nuget:?package=Walterlv.WeakEvents&version=7.3.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

This library provide weak event support. You can implement your own event in weak reference, and you can also transform existed CLR events into weak events.

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net45 net451 net452 net46 net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.
  • .NETCoreApp 3.0

    • No dependencies.
  • .NETFramework 4.5

    • No dependencies.
  • .NETStandard 2.0

    • No dependencies.

NuGet packages (2)

Showing the top 2 NuGet packages that depend on Walterlv.WeakEvents:

Package Downloads
SharpConstraintLayout.Maui

constraintlayout for maui

SharpConstraintLayout.Maui.Native

crossplatform constraintlayout at dotnet(android,ios ,windows)

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
7.3.1 65 6/13/2022
7.3.0 85 5/6/2022
7.2.0 243 1/6/2022
7.1.0 260 11/12/2021
7.0.1 157 10/18/2021
7.0.0 153 9/28/2021
6.1.0 168 9/3/2021
6.0.0 165 6/28/2021
5.15.0 176 6/25/2021
5.14.2 171 6/17/2021
5.13.0 188 3/15/2021
5.12.0 179 2/25/2021
5.11.3 296 12/15/2020
5.11.2 245 12/7/2020
5.10.3 222 12/3/2020
5.10.2 269 11/5/2020
5.10.1 249 11/5/2020
5.9.0 282 9/21/2020
5.8.0 251 8/21/2020
5.7.4 299 8/6/2020
5.7.2 286 7/31/2020
5.7.1 277 7/15/2020
5.7.0 353 7/13/2020
5.6.0 339 7/9/2020
5.5.2 328 7/9/2020
5.5.1 317 7/8/2020
5.5.0 264 7/7/2020
5.4.0 292 7/7/2020
5.3.2 287 7/3/2020
5.3.1 263 6/30/2020
5.3.0 246 6/30/2020
5.2.1 280 6/22/2020
5.2.0 342 6/21/2020
5.1.1 275 6/17/2020
5.1.0 284 6/16/2020
5.0.0 280 6/15/2020
4.0.0 281 6/12/2020
3.1.1 263 6/10/2020
3.1.0 272 6/10/2020
3.0.0 322 6/9/2020
2.3.1 351 6/9/2020
2.3.0 319 6/2/2020
2.2.1 277 6/2/2020
2.1.4 267 5/29/2020
2.1.3 322 5/23/2020
2.1.2 280 5/16/2020
2.1.1 272 5/15/2020
2.1.0 281 5/11/2020
0.15.0 309 12/25/2019
0.14.1-alpha 278 12/23/2019
0.14.0-alpha 279 12/19/2019
0.13.3-alpha 258 12/18/2019
0.13.2-alpha 254 12/6/2019
0.12.1-alpha 262 11/29/2019
0.11.0-alpha 267 11/27/2019
0.9.0-alpha 280 11/24/2019
0.8.0-alpha 256 11/20/2019
0.4.1-alpha 327 9/19/2019
0.4.0-alpha 319 9/18/2019