jquery.bgiframe 3.0.1

jQuery bgiframe

The bgiframe plugin is chainable and applies the iframe hack to get around zIndex issues in IE6. It will only apply itself in IE6 and adds a class to the iframe called 'bgiframe'. The iframe is appended as the first child of the matched element(s) with a tabIndex and zIndex of -1.

Install-Package jquery.bgiframe -Version 3.0.1
dotnet add package jquery.bgiframe --version 3.0.1
<PackageReference Include="jquery.bgiframe" Version="3.0.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add jquery.bgiframe --version 3.0.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

3.0.1
Fix default IE 6 regex
Add support for more package managers
3.0.0
Rewrite of the plugin
New conditional option (no longer restricted to IE6 only)
No longer uses CSS Expressions
Supports AMD loaders
2.1.2
Fixed visual test (test.html)
Small optimization to only check for IE once
2.1.1
Removed $.browser.version for jQuery < 1.1.3
2.1
Updated to work with jQuery 1.1.3
Added $.browser.version for jQuery < 1.1.3
Optimized duplication check by using child selector and using .length test
2.0
Added ability change settings like width, height, src and more.
1.0
Only adds iframe once per an element
Works with SSL enabled pages

Dependencies

This package has no dependencies.

Version History

Version Downloads Last updated
3.0.1 4,314 10/10/2014
3.0.0 2,524 3/12/2013
2.1.2.1 6,176 9/7/2011