AMLEditorPluginContract 1.4.0

AutomationML Editor Plugin Contract

Contract DLL for Interface Desfinitions for AutomationML Editor Plugins. An AutomationML Editor Plugin is integrated via the Microsoft Managed Extensibility Framework (MEF).

The owner has unlisted this package. This could mean that the package is deprecated or shouldn't be used anymore.
Install-Package AMLEditorPluginContract -Version 1.4.0
dotnet add package AMLEditorPluginContract --version 1.4.0
paket add AMLEditorPluginContract --version 1.4.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

This version of the AML Plugin Contract will no loner be supported. A new version, which supports CAEX 3.0 and which is based on the new version of the AML Engine is available. Please look at the new package Aml.Plugin.Contract.

This version of the AML Plugin Contract will no loner be supported. A new version, which supports CAEX 3.0 and which is based on the new version of the AML Engine is available. Please look at the new package Aml.Plugin.Contract.

Release Notes

Version 1.4
Changed to AMLEngine 3.6.0. This version can only be used with AMLEditor Version 4.9 or later.

Version 1.3
Property PackageName added to the Plugin Interface. The Name is used to update plugin versions dynamically from a NuGet Feed

Version 1.0.5.1 has a minimum dependency to AMLEngine Version 3.0

This is the first official Release of the AMLEditor Plugin Contract,
Release 1.2 build with the AMLEngine 3.2

which may be used to implement Plugins for the AutomationML Editor since Version 4.0.1.

Version History

Version Downloads Last updated