AgileObjects.NetStandardPolyfills 1.4.0

Type and Reflection polyfill extension methods for .NET Standard 1.0+ and .NET 3.5+

Install-Package AgileObjects.NetStandardPolyfills -Version 1.4.0
dotnet add package AgileObjects.NetStandardPolyfills --version 1.4.0
<PackageReference Include="AgileObjects.NetStandardPolyfills" Version="1.4.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add AgileObjects.NetStandardPolyfills --version 1.4.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes


- Adding support for .NET 3.5
- Adding PropertyInfo.IsReadable()
- Adding PropertyInfo.IsWritable()
- Adding MethodInfo.IsExtensionMethod()
- Adding MethodInfo.IsImplicitOperator()
- Adding MethodInfo.IsExplicitOperator()
- Adding MemberInfo.HasAttribute()
   

  • .NETFramework 3.5

    • No dependencies.
  • .NETFramework 4.0

    • No dependencies.
  • .NETStandard 1.0

Showing the top 2 GitHub repositories that depend on AgileObjects.NetStandardPolyfills:

Repository Stars
agileobjects/AgileMapper
A zero-configuration, highly-configurable object-object mapper with viewable execution plans. Projects queries, transforms, deep clones, updates and merges via extension methods, or a static or instance API. Targets .NET Standard 1.0+ and .NET 3.5+
agileobjects/ReadableExpressions
A .NET Standard 1.0 library and set of Debugger Visualizers which translate expression trees into readable code

Version History

Version Downloads Last updated
1.4.0 100,452 7/7/2018
1.3.0 23,929 2/6/2018
1.2.1 5,647 12/14/2017
1.2.0 786 12/2/2017
1.0.0 13,608 11/8/2017
0.2.1 11,787 5/7/2017
0.2.0 7,015 3/11/2017
0.1.2 4,643 11/11/2016
0.1.1 646 11/10/2016