FSharp.Core 4.5.2

FSharp.Core for F# 4.5

FSharp.Core redistributables from Visual F# Tools version 10.2 For F# 4.5
               Supported Platforms:
                   .NET 4.5+           (net45)
                   netstandard1.6      (netstandard1.6)
                   netstandard2.0      (netstandard2.0)
               Commit hash: bfa5fdf264c7e242b9f0436b2bf45b76e70fdeac.

Install-Package FSharp.Core -Version 4.5.2
dotnet add package FSharp.Core --version 4.5.2
paket add FSharp.Core --version 4.5.2
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

F# Core Library

This package contains functionality that supports core F# functionality, including language primitives, operators, attributes, basic types, strings, formatted I/O, F# collections, combinators for F# collections, async, native interopation constructs, and more.

Versioning

Starting with F# 4.5, this package uses the following versioning scheme:

language-major-version.language-minor-version.patch

For example, for F# 4.5, this package will reference 4.5.x, where x is a patch that may contain bug fixes or minor improvements.

When a new version of the F# language ships, the major and minor versions will be updated appropriately. To learn more about this versioning, see the versioning RFC for F#.

Usage and compatibility

This package is implicitly referenced in new projects using the .NET SDK and Visual Studio. Each time either the .NET SDK or Visual Studio ships, they will they reference to a specific version of FSharp.Core.

It is not recommended that you upgrade to a newer version until you can fully vet that it is intended for the version of the F# language you are using.

We do not guarantee forwards-compatibility with this package. That said, we do strive to ensure that newer versions can still work on older compilers. So if you upgrade to a new version that is not intended for the version of the F# language you are using, things are likely to still work, but there is a risk that some things will not.

F# Core Library

This package contains functionality that supports core F# functionality, including language primitives, operators, attributes, basic types, strings, formatted I/O, F# collections, combinators for F# collections, async, native interopation constructs, and more.

Versioning

Starting with F# 4.5, this package uses the following versioning scheme:

language-major-version.language-minor-version.patch

For example, for F# 4.5, this package will reference 4.5.x, where x is a patch that may contain bug fixes or minor improvements.

When a new version of the F# language ships, the major and minor versions will be updated appropriately. To learn more about this versioning, see the versioning RFC for F#.

Usage and compatibility

This package is implicitly referenced in new projects using the .NET SDK and Visual Studio. Each time either the .NET SDK or Visual Studio ships, they will they reference to a specific version of FSharp.Core.

It is not recommended that you upgrade to a newer version until you can fully vet that it is intended for the version of the F# language you are using.

We do not guarantee forwards-compatibility with this package. That said, we do strive to ensure that newer versions can still work on older compilers. So if you upgrade to a new version that is not intended for the version of the F# language you are using, things are likely to still work, but there is a risk that some things will not.

Version History

Version Downloads Last updated
4.5.2 70,415 7/27/2018
4.5.1 9,911 7/19/2018
4.5.0 44,874 6/7/2018
4.3.4 265,339 2/12/2018
4.3.3 40,293 1/31/2018
4.3.2 7,660 1/26/2018
4.3.1 1,828 1/25/2018
4.2.3 390,262 8/19/2017
4.2.2 41,782 7/28/2017
4.2.1 104,753 6/8/2017
4.1.18 110,529 8/19/2017
4.1.17 224,166 4/29/2017
4.0.0.1 677,468 7/23/2015
3.1.2.5 245,251 7/18/2015
3.1.2 9,174 12/3/2014
3.0.2 79,726 12/3/2014