Microsoft.DotNet.FrameworkCompatibilityDiagnostics 0.5.0

.NET Compatibility Diagnostics

A collection of analyzers for projects targeting .NET Desktop framework version 4.0+ that help identify and correct compatibility issues between version updates.

Install-Package Microsoft.DotNet.FrameworkCompatibilityDiagnostics -Version 0.5.0
dotnet add package Microsoft.DotNet.FrameworkCompatibilityDiagnostics --version 0.5.0
paket add Microsoft.DotNet.FrameworkCompatibilityDiagnostics --version 0.5.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

The .NET Compatibility Diagnostics is designed to identify possible risk areas for migration between .NET versions. Please see https://blogs.msdn.microsoft.com/dotnet/2016/03/03/net-framework-compatibility-diagnostics/ or contact netfxcompat@microsoft for more information.
   
   Release Notes:
   
   v0.5.0:

   - Added analyzers for known changes up through .NET Framework 4.6.2
   - Requires Visual Studio 2015 Update 3

   v0.4.2:
   
   - Initial release
   - Support for known breaking changes up through .NET Framework 4.6.1
   - Requires Visual Studio 2015 Update 2

Dependencies

This package has no dependencies.

Version History

Version Downloads Last updated
0.5.0 (current version) 577 10/10/2016
0.4.2 721 3/2/2016