NUnit 3.0.0-beta-2 The ID prefix of this package has been reserved for one of the owners of this package by NuGet.org. Prefix Reserved

.NET Framework 2.0
This is a prerelease version of NUnit.
There is a newer version of this package available.
See the version list below for details.
Install-Package NUnit -Version 3.0.0-beta-2
dotnet add package NUnit --version 3.0.0-beta-2
<PackageReference Include="NUnit" Version="3.0.0-beta-2" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add NUnit --version 3.0.0-beta-2
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: NUnit, 3.0.0-beta-2"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install NUnit as a Cake Addin
#addin nuget:?package=NUnit&version=3.0.0-beta-2&prerelease

// Install NUnit as a Cake Tool
#tool nuget:?package=NUnit&version=3.0.0-beta-2&prerelease
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

NUnit features a fluent assert syntax, parameterized, generic and theory tests and is user-extensible. A number of runners, both from the NUnit project and by third parties, are able to execute NUnit tests.

This package includes the NUnit 3.0 framework assembly, which is referenced by your tests. You will need to install version 3.0 of the nunit-console program or a third-party runner that supports NUnit 3.0 in order to execute tests. Runners intended for use with NUnit 2.x will not run 3.0 tests correctly.

This is an beta release, but is ready for production use for people with prior NUnit experience.

Product Versions
.NET Framework net20 net35 net40 net403 net45 net451 net452 net46 net461 net462 net463 net47 net471 net472 net48
Silverlight sl5
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (977)

Showing the top 5 NuGet packages that depend on NUnit:

Package Downloads
SpecFlow.NUnit The ID prefix of this package has been reserved for one of the owners of this package by NuGet.org.

Package to use SpecFlow with NUnit 3.13 and later

AutoFixture.NUnit3 The ID prefix of this package has been reserved for one of the owners of this package by NuGet.org.

By leveraging some features of NUnit3, this extension turns AutoFixture into a declarative framework for writing unit tests. In many ways it becomes a unit testing DSL (Domain Specific Language).

NUnitLite The ID prefix of this package has been reserved for one of the owners of this package by NuGet.org.

NUnitLite provides a simple way to run NUnit tests, without the overhead of a full NUnit installation. It is suitable for projects that want to have a quick way to run tests using a console runner and don't need all the features of the NUnit engine and console runner. Supported platforms: - .NET Framework 3.5+ - .NET Standard 2.0+ - .NET Core 2.1+ How to use this package: 1. Create a console application for your tests and delete the generated class containing Main(). 2. Install the NUnitLite package, which creates a new Main() as well as adding a reference to NUnitLite. This will also bring in the NUnit package, which adds a reference to the NUnit framework to your project. 3. Add your tests to the test project and simply start the project to execute them.

MassTransit.TestFramework The ID prefix of this package has been reserved for one of the owners of this package by NuGet.org.

MassTransit Test Framework (NUnit); MassTransit is a message-based distributed application framework for .NET http://masstransit-project.com

ppy.osu.Framework

A 2D application/game framework written with rhythm games in mind.

GitHub repositories (1.1K)

Showing the top 5 popular GitHub repositories that depend on NUnit:

Repository Stars
Wox-launcher/Wox
Launcher for Windows, an alternative to Alfred and Launchy.
dotnet/maui
.NET MAUI is the .NET Multi-platform App UI, a framework for building native device applications spanning mobile, tablet, and desktop.
icsharpcode/ILSpy
.NET Decompiler with support for PDB generation, ReadyToRun, Metadata (&more) - cross-platform!
Ryujinx/Ryujinx
Experimental Nintendo Switch Emulator written in C#
OpenRA/OpenRA
Open Source real-time strategy game engine for early Westwood games such as Command & Conquer: Red Alert written in C# using SDL and OpenGL. Runs on Windows, Linux, *BSD and Mac OS X.
Version Downloads Last updated
3.13.3 4,617,780 3/20/2022
3.13.2 19,534,768 4/27/2021
3.13.1 9,611,573 2/1/2021
3.13.0 3,388,773 1/7/2021
3.12.0 52,551,150 5/15/2019
3.11.0 21,003,422 10/7/2018
3.10.1 14,746,333 3/13/2018
3.10.0 332,091 3/13/2018
3.9.0 7,557,879 11/10/2017
3.8.1 15,578,173 8/29/2017
3.8.0 278,538 8/28/2017
3.7.1 3,387,573 6/6/2017
3.7.0 814,025 5/30/2017
3.6.1 4,294,279 2/26/2017
3.6.0 2,122,121 1/10/2017
3.5.0 3,525,316 10/4/2016
3.4.1 2,121,674 6/30/2016
3.4.0 136,489 6/25/2016
3.2.1 1,122,286 4/19/2016
3.2.0 822,254 3/5/2016
3.0.1 1,633,439 12/2/2015
3.0.0 739,545 11/16/2015
3.0.0-rc-3 7,501 11/14/2015
3.0.0-rc-2 8,036 11/8/2015
3.0.0-rc 9,022 11/1/2015
3.0.0-beta-5 16,423 10/17/2015
3.0.0-beta-4 13,925 8/25/2015
3.0.0-beta-3 14,436 7/15/2015
3.0.0-beta-2 19,902 5/13/2015
3.0.0-beta-1 11,359 3/26/2015
3.0.0-alpha-5 20,604 1/31/2015
3.0.0-alpha-4 11,155 12/31/2014
3.0.0-alpha-3 10,182 11/29/2014
3.0.0-alpha-2 20,099 11/3/2014
3.0.0-alpha 20,375 9/23/2014
2.7.1 242,384 8/21/2019
2.7.0 216,479 8/10/2018
2.6.7 116,408 7/7/2018
2.6.6 28,116 6/7/2018
2.6.5 73,988 4/20/2018
2.6.4 11,365,830 12/17/2014
2.6.3 5,017,524 10/11/2013
2.6.2 2,228,044 10/23/2012
2.6.1 376,967 8/5/2012
2.6.0.12054 603,033 2/24/2012
2.5.10.11092 731,894 4/25/2011
2.5.9.10348 104,833 2/9/2011
2.5.7.10213 380,638 1/7/2011

This package includes the NUnit 3.0 framework assembly, which is referenced by your tests. You will need to install version 3.0 of the nunit-console program or a third-party runner that supports NUnit 3.0 in order to execute tests. Runners intended for use with NUnit 2.x will not run 3.0 tests correctly.

This is an beta release, but is ready for production use for people with prior NUnit experience.