NWebsec 5.0.0

NWebsec is an easy to use security library for ASP.NET applications. With a few lines of config it lets you set important security headers, detect potentially dangerous redirects, control cache headers, and remove version headers. See project website for documentation.

There is a newer version of this package available.
See the version list below for details.
Install-Package NWebsec -Version 5.0.0
dotnet add package NWebsec --version 5.0.0
paket add NWebsec --version 5.0.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

This release adds support for the Referrer-Policy header and the CSP 'strict-dynamic' directive. Drops support for .NET < 4.5. See release notes on GitHub for details.

Version History

Version Downloads Last updated
5.1.1 54,776 3/26/2018
5.1.0 263 3/25/2018
5.0.0 1,157 3/13/2018
4.3.0 166,554 12/7/2016
4.2.0 98,994 10/25/2015
4.1.1 19,383 6/17/2015
4.1.0 452 6/13/2015
4.0.0 9,137 2/16/2015
3.2.0 14,922 10/13/2014
3.1.0 376 10/7/2014
3.0.2 2,253 4/18/2014
3.0.1 1,664 1/30/2014
3.0.0 1,366 11/12/2013
2.2.1 5,961 4/29/2013
2.2.0 369 4/1/2013
2.1.0 896 2/17/2013
2.0.1 416 2/8/2013
2.0.0 378 2/3/2013
1.1.1 555 10/8/2012
1.1.0 409 10/7/2012
1.0.2 415 9/2/2012
1.0.1 392 8/20/2012