azureutilities 1.0.6-rc0004

.NET Core 2.2
This is a prerelease version of azureutilities.
dotnet tool install --global azureutilities --version 1.0.6-rc0004
This package contains a .NET tool you can call from the shell/command line.
dotnet new tool-manifest # if you are setting up this repo
dotnet tool install --local azureutilities --version 1.0.6-rc0004
This package contains a .NET tool you can call from the shell/command line.
#tool dotnet:?package=azureutilities&version=1.0.6-rc0004&prerelease
nuke :add-package azureutilities --version 1.0.6-rc0004

Azure Utilities

A simple dotnet global tool with a collection of utilities to interact with various Azure services. This tool was predominantly built for personal use so that the utilities can be run in the build and release pipelines.

Installation

Global Tool:

dotnet tool install --global azureutilities

To update it to the latest version, if it was installed previously, use:

dotnet tool update --global azureutilities
Requirements
  • You need to be running .NET Core SDK v2.2 and above on your computer (Linux, Windows or Mac)
  • For detailed installation steps of .NET Core SDK, refer the documentation for your platform

Usage

Once you have installed tool globally, you can run the tool using azureutilities command.

More information

Refer to wiki

Troubleshoot

Ubuntu v18.04 Windows Subsystem Linux

  • Issue: After installing this as a global tool, if you try run azureutilities command, you get error as azureutilities: command not found <br/> Resolution: On Linux system, .NET Core global tools are by default installed under path $HOME/.dotnet/tools. This path is not available in $PATH. The fix is to append $HOME/.dotnet/tools to $PATH using command PATH=$PATH:$HOME/.dotnet/tools
Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

This package has no dependencies.

Version Downloads Last updated
1.0.6-rc0004 348 8/18/2019
1.0.5 478 8/18/2019
1.0.3 391 8/17/2019