swigged.llvm 4.0.5-alpha

A SWIG-generated C# API of LLVM-C.

This is a prerelease version of swigged.llvm.
There is a newer version of this package available.
See the version list below for details.
Install-Package swigged.llvm -Version 4.0.5-alpha
dotnet add package swigged.llvm --version 4.0.5-alpha
<PackageReference Include="swigged.llvm" Version="4.0.5-alpha" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add swigged.llvm --version 4.0.5-alpha
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: swigged.llvm, 4.0.5-alpha"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install swigged.llvm as a Cake Addin
#addin nuget:?package=swigged.llvm&version=4.0.5-alpha&prerelease

// Install swigged.llvm as a Cake Tool
#tool nuget:?package=swigged.llvm&version=4.0.5-alpha&prerelease
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

This version corrects a problems with versions 4.0.3 and 4.0.4. DllImport now works across Windows 10 and Ubuntu 16.04. Due to a problem with Net Core/Standard, I found out that one cannot name a DLL or SO file with dots in the file name other than the dot before the suffix. E.g., swigged.llvm.native.dll must be swigged-llvm-native.dll.
     
This API links statically with LLVM version 4.0+ branch. You do not need to install LLVM. As LLVM does not tag the branch, the sources used in the build may vary.

The DLL and SO files provided in this package are a Release build.

This package is Net Standard 1.1 build, so it should work in Net Framework >=4.5.

When building, either on Windows or Ubuntu, select Platform = "AnyCPU", config = "Debug" or "Release".

On Windows, in the properties for the executable, un-check "Prefer 32-bit" in Build properties, and check "Enable native code debugging". If you are using Net Core or Standard, this option is unavailable--I'm not sure why it is.

On Ubuntu, use Net Core to build your C# program.

Targets currently built for std.swigged.llvm are net45, net461, netstandard1.6. Targets for swigged-llvm-native (the native wrapper library for LLVM-C) is built for win10-x86, win10-x64, and ubuntu.16.04-x64. The appropriate swigged-llvm-native.dll/so file should be to your build directory in order to run.
     
For further information, see https://github.com/kaby76/swigged-llvm.

NuGet packages (1)

Showing the top 1 NuGet packages that depend on swigged.llvm:

Package Downloads
Campy
A compiler, runtime, and API for GP-GPU computing using C# or any other NET language, for Windows and Ubuntu x64.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
70.0.1 1,064 9/23/2018
70.0.0 513 8/29/2018
6.0.6 975 5/2/2018
6.0.5 610 4/18/2018
6.0.4 899 4/4/2018
6.0.3 992 3/9/2018
6.0.0.2-alpha 596 2/5/2018
6.0.0.1-alpha 618 1/10/2018
5.0.4 719 1/5/2018
5.0.3 704 10/23/2017
5.0.2 700 9/22/2017
5.0.1 740 9/16/2017
4.0.14 746 9/6/2017
4.0.13 748 9/6/2017
4.0.12 909 9/5/2017
4.0.11 706 6/18/2017
4.0.10 834 6/16/2017
4.0.9-alpha 510 5/26/2017
4.0.8-alpha 483 5/25/2017
4.0.7-alpha 554 5/24/2017
4.0.6-alpha 544 5/18/2017
4.0.5-alpha 503 5/11/2017
4.0.4-alpha 613 5/9/2017
4.0.3-alpha 536 5/8/2017
4.0.1.2-alpha 631 4/17/2017
4.0.1.1-alpha 607 4/6/2017
Show less