BotSharp.Core 0.4.0

.NET Standard 2.0
dotnet add package BotSharp.Core --version 0.4.0
NuGet\Install-Package BotSharp.Core -Version 0.4.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="BotSharp.Core" Version="0.4.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add BotSharp.Core --version 0.4.0
#r "nuget: BotSharp.Core, 0.4.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install BotSharp.Core as a Cake Addin
#addin nuget:?package=BotSharp.Core&version=0.4.0

// Install BotSharp.Core as a Cake Tool
#tool nuget:?package=BotSharp.Core&version=0.4.0

Open source AI Bot platform builder which is written in C# runs on .Net Core and is enterprise oriented. Integrated with multiple bot engines besides BotSharp bot engine. Modulized pipeline design make NLP tasks plugin easily. Abstract platform and NLP task, migrate existed chatbot from a platform into another platform perfectly through dump and restore.

If you feel that this project is helpful to you, please Star on the project, we will be very grateful.

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows net7.0 net7.0-android net7.0-ios net7.0-maccatalyst net7.0-macos net7.0-tvos net7.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net461 net462 net463 net47 net471 net472 net48 net481
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (3)

Showing the top 3 NuGet packages that depend on BotSharp.Core:

Package Downloads
FenixAlliance.ACL.Dependencies

Application Component for the Alliance Business Suite.

BotSharp.Platform.Dialogflow

BotSharp platform emulator which is compatible with Google Dialogflow.

BotSharp.Channel.Weixin

Package Description

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
0.4.0 292,756 2/23/2019

Support dialogue status tracking.