Novalys.VisualGuard.Security 2024.0.2403.18

dotnet add package Novalys.VisualGuard.Security --version 2024.0.2403.18
NuGet\Install-Package Novalys.VisualGuard.Security -Version 2024.0.2403.18
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Novalys.VisualGuard.Security" Version="2024.0.2403.18" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Novalys.VisualGuard.Security --version 2024.0.2403.18
#r "nuget: Novalys.VisualGuard.Security, 2024.0.2403.18"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install Novalys.VisualGuard.Security as a Cake Addin
#addin nuget:?package=Novalys.VisualGuard.Security&version=2024.0.2403.18

// Install Novalys.VisualGuard.Security as a Cake Tool
#tool nuget:?package=Novalys.VisualGuard.Security&version=2024.0.2403.18

This package provides a core VisualGuard library, for accessing VisualGuard runtime and VisualGuard entities.
     Ex. Create user, Authenticate user, Create Role, Create Group, Create permission, Grant/revoke role to a user, Grant/revoke permission to role, etc.

     Note: Please make sure you are using the same nuget package versions for your applications as of VisualGuard WinConsole.
     If you have the Visual-Guard WinConsole Runtime version '2024.0.2403.18', you must have all packages with version '2024.0.2403.18'

     About VisualGuard:
     Visual Guard is a modular solution, which covers most application security requirements, from application-level security systems to Corporate Identity and Access Management Solutions. It provides :
     -> Security framework for application developers
     -> Access control for business applications
     -> Identity Access Management
     -> Powerful user accounts and groups management features
     -> Monitor and Audit sensitive activities
     -> Send email notifications for important events

     For details, Please visit: https://www.visual-guard.com/    
     You must download VisualGuard WinConsole to secure your applications.
     Download Visual Guard 2024.0 Express Edition (Free) : http://visual-guard.com/VG-Express

     See, How to integrate Visual Guard with your applications:
     WinForm       -     https://www.visual-guard.com/VG-Winform
     WPF           -     https://www.visual-guard.com/VG-WPF
     WebForm       -     https://www.visual-guard.com/VG-WebForm
     WebService    -     https://www.visual-guard.com/VG-WebService
     MVC           -     https://www.visual-guard.com/VG-MVC
     .Net Core Web -     https://www.visual-guard.com/VG-WebCore
     Angular       -     https://www.visual-guard.com/VG-Angular
     WCF           -     https://www.visual-guard.com/VG-WCF
     SharePoint    -     https://www.visual-guard.com/VG-sharepoint

     Supported Platforms:
     .NET Standard 2.0 or Higher, .NET Framework 4.7.2 or Higher, .NET Core 2.0 or higher, Angular 7.0 or higher

     You need to download few more packages also.

     -> Package depending on Database Storage
     -----------------------
     Download package responsible for data operations depending on the type of your storage. (SQLServer, Oracle, File etc)
     Ex. If VisualGuard repository is in SQLServer, choose Novalys.VisualGuard.Security.SQLServer package.
     Packages:
     -> Novalys.VisualGuard.Security.SQLServer
     -> Novalys.VisualGuard.Security.Oracle
     -> Novalys.VisualGuard.Security.File
     -> Novalys.VisualGuard.Security.VGServerClient

     -> Package depending on Technology of Application
     ----------------------------------------
     Download package responsible for securing specific type of application (Winform, WPF, WebForm, etc)
     Ex. If application is WPF application, choose Novalys.VisualGuard.Security.WPF package.
     Packages:
     -> Novalys.VisualGuard.Security.WinForm
     -> Novalys.VisualGuard.Security.WPF
     -> Novalys.VisualGuard.Security.WebForm
     -> Novalys.VisualGuard.Security.WebService
     -> Novalys.VisualGuard.Security.WebMvc
     -> Novalys.VisualGuard.Security.CRM
     -> Novalys.VisualGuard.Security.SharePoint
     -> Novalys.VisualGuard.Security.WebForm.Core
     -> Novalys.VisualGuard.Security.Angular

     -> Package depending on Framework of Application
     -------------------------------------------------
     Download package responsible for securing application with specific framework type(.net framework or .net core etc)
     Ex. If application is built with .net framework, choose Novalys.VisualGuard.Security.NetFramework package)
     Packages:
     -> Novalys.VisualGuard.Security.NetFramework
     -> Novalys.VisualGuard.Security.Core

Product Compatible and additional computed target framework versions.
.NET net5.0 was computed.  net5.0-windows was computed.  net6.0 was computed.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp2.0 is compatible.  netcoreapp2.1 is compatible.  netcoreapp2.2 is compatible.  netcoreapp3.0 was computed.  netcoreapp3.1 was computed. 
.NET Standard netstandard2.0 is compatible.  netstandard2.1 was computed. 
.NET Framework net461 was computed.  net462 was computed.  net463 was computed.  net47 was computed.  net471 was computed.  net472 is compatible.  net48 was computed.  net481 was computed. 
MonoAndroid monoandroid was computed. 
MonoMac monomac was computed. 
MonoTouch monotouch was computed. 
Tizen tizen40 was computed.  tizen60 was computed. 
Xamarin.iOS xamarinios was computed. 
Xamarin.Mac xamarinmac was computed. 
Xamarin.TVOS xamarintvos was computed. 
Xamarin.WatchOS xamarinwatchos was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (8)

Showing the top 5 NuGet packages that depend on Novalys.VisualGuard.Security:

Package Downloads
Novalys.VisualGuard.Security.SQLServer

This package is required for data operations when SQL Server is used as VisualGuard repository. Note: Please make sure you are using the same nuget package versions for your applications as of VisualGuard WinConsole. If you have the Visual-Guard WinConsole Runtime version '2024.0.2403.18', you must have all packages with version '2024.0.2403.18' About VisualGuard: Visual Guard is a modular solution, which covers most application security requirements, from application-level security systems to Corporate Identity and Access Management Solutions. It provides : -> Security framework for application developers -> Access control for business applications -> Identity Access Management -> Powerful user accounts and groups management features -> Log data processing via the application -> Monitor and Audit sensitive activities -> Send email notifications for important events For details, Please visit: https://www.visual-guard.com/ You must download VisualGuard WinConsole to secure your applications. Download Visual Guard 2024.0 Express Edition (Free) : http://visual-guard.com/VG-Express Supported Platforms: ->.NET Standard 2.0 or Higher ->.NET Framework 4.7.2 or Higher ->.NET Core 2.0 or higher -> Angular 7.0 or higher You will also require other packages as shown below. Package depending on Technology of Application ---------------------------------------- Download nuget package responsible for securing specific type of application (Winform, WPF, WebForm, etc) Ex. If your application is WPF application, choose Novalys.VisualGuard.Security.WPF nuget package. Packages: -> Novalys.VisualGuard.Security.Winform -> Novalys.VisualGuard.Security.WPF -> Novalys.VisualGuard.Security.WebForm -> Novalys.VisualGuard.Security.WebService -> Novalys.VisualGuard.Security.WebMvc -> Novalys.VisualGuard.Security.CRM -> Novalys.VisualGuard.Security.SharePoint -> Novalys.VisualGuard.Security.WebForm.Core -> Novalys.VisualGuard.Security.Angular Package depending on Framework of Application ------------------------------------------------- Download nuget package responsible for securing application with specific framework type(.net framework or .net core etc) Ex. If your application is built with .net framework, choose Novalys.VisualGuard.Security.NetFramework nuget package) Packages: -> Novalys.VisualGuard.Security.NetFramework -> Novalys.VisualGuard.Security.Core

Novalys.VisualGuard.Security.Core

This package is required for securing .NET Core applications. Note: Please make sure you are using the same nuget package versions for your applications as of VisualGuard WinConsole. If you have the Visual-Guard WinConsole Runtime version '2024.0.2403.18', you must have all packages with version '2024.0.2403.18' About VisualGuard: Visual Guard is a modular solution, which covers most application security requirements, from application-level security systems to Corporate Identity and Access Management Solutions. It provides : -> Security framework for application developers -> Access control for business applications -> Identity Access Management -> Powerful user accounts and groups management features -> Log data processing via the application -> Monitor and Audit sensitive activities -> Send email notifications for important events For details, Please visit: https://www.visual-guard.com/ Download Visual Guard 2024.0 Express Edition (Free) : http://visual-guard.com/VG-Express Supported Platforms: ->.NET Standard 2.0 or Higher ->.NET Framework 4.7.2 or Higher ->.NET Core 2.0 or higher -> Angular 7.0 or higher You will also require other packages as shown below. Package depending on Technology of Application ---------------------------------------- Download nuget package responsible for securing specific type of application (.net core WebForm , .net core angular, etc) Ex. If your application is .Net Core Web application, choose Novalys.VisualGuard.Security.WebForm.Core nuget package. Packages: -> Novalys.VisualGuard.Security.WebForm.Core -> Novalys.VisualGuard.Security.Angular Package depending on Database Storage ------------------------------------- Download nuget package responsible for data operations depending on the type of your storage. (SQLServer, Oracle, File etc) Ex. If your VisualGuard repository is in SQLServer, choose Novalys.VisualGuard.Security.SQLServer nuget package. Packages: -> Novalys.VisualGuard.Security.SQLServer -> Novalys.VisualGuard.Security.Oracle -> Novalys.VisualGuard.Security.File -> Novalys.VisualGuard.Security.VGServerClient

Novalys.VisualGuard.Security.VGServerClient

This package is required for data operations when VGServer is used as VisualGuard repository. Note: Please make sure you are using the same nuget package versions for your applications as of VisualGuard WinConsole. If you have the Visual-Guard WinConsole Runtime version '2024.0.2403.18', you must have all packages with version '2024.0.2403.18' About VisualGuard: Visual Guard is a modular solution, which covers most application security requirements, from application-level security systems to Corporate Identity and Access Management Solutions. It provides : -> Security framework for application developers -> Access control for business applications -> Identity Access Management -> Powerful user accounts and groups management features -> Log data processing via the application -> Monitor and Audit sensitive activities -> Send email notifications for important events For details, Please visit: https://www.visual-guard.com/ You must download VisualGuard WinConsole to secure your applications. Download Visual Guard 2024.0 Express Edition (Free) : http://visual-guard.com/VG-Express Supported Platforms: ->.NET Standard 2.0 or Higher ->.NET Framework 4.7.2 or Higher ->.NET Core 2.0 or higher -> Angular 7.0 or higher You will also require other packages as shown below. Package depending on Technology of Application ---------------------------------------- Download nuget package responsible for securing specific type of application (Winform, WPF, WebForm, etc) Ex. If your application is WPF application, choose Novalys.VisualGuard.Security.WPF nuget package. Packages: -> Novalys.VisualGuard.Security.Winform -> Novalys.VisualGuard.Security.WPF -> Novalys.VisualGuard.Security.WebForm -> Novalys.VisualGuard.Security.WebService -> Novalys.VisualGuard.Security.WebMvc -> Novalys.VisualGuard.Security.CRM -> Novalys.VisualGuard.Security.SharePoint -> Novalys.VisualGuard.Security.WebForm.Core -> Novalys.VisualGuard.Security.Angular Package depending on Framework of Application ------------------------------------------------- Download nuget package responsible for securing application with specific framework type(.net framework or .net core etc) Ex. If your application is built with .net framework, choose Novalys.VisualGuard.Security.NetFramework nuget package) Packages: -> Novalys.VisualGuard.Security.NetFramework -> Novalys.VisualGuard.Security.Core

Novalys.VisualGuard.Security.Oracle

This package is required for data operations when Oracle is used as VisualGuard repository. Note: Please make sure you are using the same nuget package versions for your applications as of VisualGuard WinConsole. If you have the Visual-Guard WinConsole Runtime version '2024.0.2403.18', you must have all packages with version '2024.0.2403.18' About VisualGuard: Visual Guard is a modular solution, which covers most application security requirements, from application-level security systems to Corporate Identity and Access Management Solutions. It provides : -> Security framework for application developers -> Access control for business applications -> Identity Access Management -> Powerful user accounts and groups management features -> Log data processing via the application -> Monitor and Audit sensitive activities -> Send email notifications for important events For details, Please visit: https://www.visual-guard.com/ You must download VisualGuard WinConsole to secure your applications. Download Visual Guard 2024.0 Express Edition (Free) : http://visual-guard.com/VG-Express Supported Platforms: ->.NET Standard 2.0 or Higher ->.NET Framework 4.7.2 or Higher ->.NET Core 2.0 or higher -> Angular 7.0 or higher You will also require other packages as shown below. Package depending on Technology of Application ---------------------------------------- Download nuget package responsible for securing specific type of application (Winform, WPF, WebForm, etc) Ex. If your application is WPF application, choose Novalys.VisualGuard.Security.WPF nuget package. Packages: -> Novalys.VisualGuard.Security.Winform -> Novalys.VisualGuard.Security.WPF -> Novalys.VisualGuard.Security.WebForm -> Novalys.VisualGuard.Security.WebService -> Novalys.VisualGuard.Security.WebMvc -> Novalys.VisualGuard.Security.CRM -> Novalys.VisualGuard.Security.SharePoint -> Novalys.VisualGuard.Security.WebForm.Core -> Novalys.VisualGuard.Security.Angular Package depending on Framework of Application ------------------------------------------------- Download nuget package responsible for securing application with specific framework type(.net framework or .net core etc) Ex. If your application is built with .net framework, choose Novalys.VisualGuard.Security.NetFramework nuget package) Packages: -> Novalys.VisualGuard.Security.NetFramework -> Novalys.VisualGuard.Security.Core

Novalys.VisualGuard.Security.Angular

This package is required for securing a .net core Angular application using VisualGuard. Note: Please make sure you are using the same nuget package versions for your applications as of VisualGuard WinConsole. If you have the Visual-Guard WinConsole version 2019.1, you must have all packages with version 2019.1.X About VisualGuard: Visual Guard is a modular solution, which covers most application security requirements, from application-level security systems to Corporate Identity and Access Management Solutions. It provides : -> Security framework for application developers -> Access control for business applications -> Identity Access Management -> Powerful user accounts and groups management features -> Log data processing via the application -> Monitor and Audit sensitive activities -> Send email notifications for important events For details, Please visit: https://www.visual-guard.com/ 'Visual Guard 2019 Express Edition' comes with Console having rich and easy to understand 'User interface' to manage all VisualGuard entities (ex. Users, Roles, Permissions, etc), You must download it to secure your applications. Download Visual Guard 2019 Express Edition (Free) : http://visual-guard.com/VG-Express See, How to integrate Visual Guard in Angular applications: https://www.visual-guard.com/VG-Angular Supported Platforms: ->.NET Standard 2.0 or Higher ->.NET Framework 4.7.2 or Higher ->.NET Core 2.1 or higher -> Angular 7.0 or higher You will also require other packages as shown below. Package depending on Database Storage ------------------------------------- Download nuget package responsible for data operations depending on the type of your storage. (SQLServer, Oracle, File etc) Ex. If your VisualGuard repository is in SQLServer, choose Novalys.VisualGuard.Security.SQLServer nuget package. Packages: -> Novalys.VisualGuard.Security.SQLServer -> Novalys.VisualGuard.Security.Oracle -> Novalys.VisualGuard.Security.File -> Novalys.VisualGuard.Security.VGServerClient Package depending on Framework of Application ------------------------------------------------- Download nuget package responsible for securing application with specific framework type(.net framework or .net core etc) Ex. If your application is built with .net framework, choose Novalys.VisualGuard.Security.NetFramework nuget package) Packages: -> Novalys.VisualGuard.Security.NetFramework -> Novalys.VisualGuard.Security.Core

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
2024.0.2403.18 37 6/21/2024
2020.3.2311.24 756 11/24/2023
2020.3.2311.8 604 11/9/2023
2020.3.2307.19 754 8/24/2023
2020.2.2210.20 2,034 11/16/2022
2019.2.2309.27 653 9/28/2023
2019.2.2303.30 876 7/11/2023
2019.1.44 2,932 9/22/2022
2019.1.42 2,240 8/26/2022
2019.1.39 1,467 12/23/2021
2019.1.37 1,559 11/12/2021
2019.1.32 2,028 5/14/2021
2019.1.31 1,643 5/4/2021
2019.1.30 1,753 4/22/2021
2019.1.29 2,000 4/15/2021
2019.1.16 2,056 2/27/2020
2019.1.14 1,754 1/16/2020
2019.1.13 1,946 1/3/2020
2019.1.9 2,001 12/4/2019
2019.1.4 1,956 10/11/2019
2019.0.21 2,041 8/30/2019
2019.0.18 2,021 8/12/2019
2019.0.17 1,972 6/28/2019
2019.0.16 1,919 6/25/2019
2019.0.15 1,962 6/24/2019